Helsinki Terrestrial Cable Outages

Incident Report for GSL

Resolved

As of roughly 3 hours ago the terrestrial wave between Helsinki and Amsterdam has been restored, reconnecting Helsinki to our backbone.

The terrestrial wave between Helsinki to Warsaw is also expected to be restored within the next hour.

We are expecting no further impacts at this time and have received the all clear from our vendors.
Posted Apr 25, 2025 - 02:55 UTC

Investigating

We have identified multiple cable outages impacting connectivity to our Helsinki POP. These multiple breaks have impacted multiple cables between Helsinki to Amsterdam and Helsinki to Warsaw.

We have contacted our suppliers for further updates.
Posted Apr 24, 2025 - 22:44 UTC
This incident affected: IP Transit ((EU) Helsinki) and Backbone Network ((EU) Helsinki).