Jupiter Cable Offline
Incident Report for GSL
Resolved
The cable system issues have been resolved, and express pathway connectivity has been successfully restored between Los Angeles and Tokyo.
Posted Oct 24, 2023 - 05:29 UTC
Identified
We have observed an outage on the Jupiter submarine cable system between Los Angeles and Tokyo.
Traffic has automatically redirected via alternative paths.
Posted Oct 13, 2023 - 04:30 UTC
This incident affected: IP Transit ((JP) Tokyo, (USA) Los Angeles) and Backbone Network ((JP) Tokyo, (USA) Los Angeles).